Verilog Module Tutorial

By TA Brian W. Stevens — CMPE415 — UMBC Spring 2015 — Dr. Tinoosh Mohsenin

What will this guide teach you?

This guide will go through how to use Xilinx 13.2 to create a Verilog module for a simple 8 bit
multiplier. It will show you how to add files to Xilinx projects and how to incorporate a testbench for
your Verilog module. There are also some other helpful tips as well.
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2. Create New Project
a. On the top toolbar go to File > New Project
b. Name your project and select the location for the project

& New Project Wizard

Specify project location

Mame:
Location:

Working Directory:

Create New Project

and type.

Enter a name, locations, and comment for the project

ExampleProject
D:\ExampleProject

D:\ExampleProject

B

Description:

This is a simple example project for an 8-bit multiplier,

HDOL

Select the type of top-evel source for the project

TopHevel source type:

vt | [ concal |

c. Click Next



3. Project Settings

a. Enter the following information about your FPGA. This information is also under

“Spartan-3E FPGA Family: Data Sheet” under Package Marking (page 6).

http://www.xilinx.com/support/documentation/data_sheets/ds312.pdf

@ Mew Project Wizard

Project Settings

Specify device and project properties.

Select the device and design flow for the project

Property Mame

Evaluation Development Board
Product Category

Family

Device

Package

Speed

Top-Level Source Type

Synthesis Tool

Simulater

Preferred Language

Property Specification in Project File
Manual Compile Order

WHODL Source Analysis Standard

Enable Mezszage Filtering

Value

Mone Specified
General Purpose
Spartan3E
#C35500E
FG320

-4

HDL

X5T (WHDL Verilog)
ISim (VHDL/ Verilog)
Verilog

Store all values

]
VHDL-93

=]

0| |EN|EN|EN[ER

[ [EgEE]

Mext

|| canc

b. Click Next




e Helpful Hint #2 — you can change the settings of your FPGA Board(Speed, Family, Package... ect)
by right clicking your project tree and selecting “Design Properties”

| Design «+08 x|
E View: @) !:E:I}Implememaﬁcn (@] @Simulaﬁcn i
g Hierarchy E
18| ExampleProjectl .;
EX # xc3s500e-dia0
o L[]t Ei [I] New Source...
?J E| Add Source... .
g Add Copy of Source... :
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m @ Implement Top Module 1
File/Path Display 3 E
Expand All §
Collapse All N
My Find... Ctrl+F

#. Design Properties...

P Mo Processes Running

Ne single design module is selected.
-3 Design Utilities
~ P2 Update All Schematic Files
- fQ  Compile HDL Simulation Libraries
Regenerate All Cores
Check All Core Versions
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& Start | B} Design |E Files |E Libraries E



4. Project Summary Displayed

@ Mew Project Wizard

Project Summary

Project Mavigator will create a new project with the following spedfications.

Project:
Project Name: ExampleProjectl
Froject Path: D:\ExampleProjectl
Working Directory: D:\ExampleProjectl
Description: This i= a simple example project for an B-bit multiplier.
Top Level Source Type: HDL

Device:
Device Family: Spartan3E
Device: xc3s500e
Package: fg320
Epeed: -4

Top-Level Source Type: HDL

Synthesgis Tool: X5T (VHDL/Verilog)

Simmlator: ISim (VHDL/Verilog)

Preferred Language: Verilog

Property Specification in Project File: Store all wvalues
Manual Compile Crder: false

VHDL Source Analysis Standard: VHDL-93

Message Filtering: disabled

»

m

[ Finish ] [ Cancel

a. Click Finish



5. Project ISE Display
a. Your project environment will be displayed as seen below.
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6. Create a New Source
a. Rightclick on the project and select “New Source” as seen below OR go to
Project > New Source OR you can use the buttons to the left of the hierarchy tree

& ISE Project Navigator (0.61xd) - DiEampleProjectl\ExampleProjectlaise -
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e Helpful Tip #1 — here you can also add existing Verilog and other source files to your design, here

are the options

a. New Source - starts wizard to create a new source _le (Verilog, VHDL, Schematic, etc...),

creating a shell if desired, and adds it for use in the project.

b. Add Source - Allows you to point to a source _le in the project directory or anywhere

else and include it for use in the project
c. Add Copy of Source - Creates a copy of the source _le in the project directory and adds

the copy for use in the project

7. New Source Type and File Name

a. After clicking “New Source”, select “Verilog Module” as the file type and enter the file

name(here as “Eight_Bit_Multipler”) as seen below.

& New Source Wizard

Select Source Type

Select source type, file name and its location.

P (CORE Generator & Architecture Wizard)
Schematic

System Generator Project
User Document

Verilog Module

Verilog Test Fixture
YHOL Medule

YHDL Library

YHDL Package

| VHDL Test Bench

E Embedded Processor

File name:
Eight_Bit_Multiplier
Location:

D:\ExampleProject1

Add to project

Mext

|| cancel




8. Pre-define Inputs and Outputs
a. This window allows you to enter in your pre-defined inputs and outputs. This step will
automatically create a template module for you with the inputs and outputs you type
below. However, this is not required and you can always just select “Next” and change
the inputs and outputs later.

| = |
@ New Source Wizard
Define Module
Specify ports for module,
Module name | Eight_Bit_Multiplier
Port Name Direction Bus M5B LSBE it
in0 input IZ| 7 0
inl input IZ| 7 0
clk input |Z| O
out output |Z| 15 0
input |Z| [
input IZ| [
input |Z| [
input |Z| [
input |Z| [
input |Z| [
input |z| 0
input |z| 0

Next l ’ Cancel

b. Click Next



9. Summary Displayed

Displays a summary of the file you are creating, lists inputs/outputs ect.

a.
[ |
@ Mew Source Wizard

Summary
Praject Mavigator will create a new skeleton source with the following spedifications.
Add to Project: Yes
Source Directory: D:\ExampleProjectl
Source Type: Verilog Module
Source Mame: Eight_Bit_Multiplier.v
Module name: Eight_Bit_Multiplier
Port Definitions:

inQ Bus: 0 input

in1 Bus: 70 input

dk Pin input

out Bus: 15:0 output

[ Finish J ’ Cancel

b. Click Finish




10. New Verilog File Displayed
a. This will now show your added file in the ISE environment.
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b. You will notice that the Verilog module has been added under your project
tree(hierarchy)

Design +085 X
View: @) {E:J:EImplemenEﬁon ) @Simulaﬁon

Hierarchy
b ExampleProjectl
= Ed xc3s500e-4fg320
ﬂnﬂ Eight_Bit_Multiplier (Eight_Bit_Multiplier.v)

H|E B || | e =




c. Your new file will show your auto-generated Verilog module with any inputs and
outputs already previously defined.

1 “t,'_rr.esca'_e ins / 1ps

2 SILIEITETETEL AT PP E BT R P T AL P EF L EL LTI P PRSP T R FET ST ET AL E T AL i PP ii i iiliies
3 // Company:

4 // Engineer:

5 //
&

T

]

// Create Date: 13:05:37 02/08/2015
// Design Name:

[/ Module Name: Eight_Bit_Multiplier
g // Project Name:

10 // Target Devices:

11 // Tool versions:

12 // Description:

i3/
// Dependencies:
s/

16 // Revision:

17 // Revision 0.01 - File Created

18 // Additional Comments:

13 [/

20 SEIESTELITILPTEEEELEETLLPT AL L PR PP IETE P TALFEA I BT LT P PRI P E L ET I P Pii ity
21 module Eight Bit Multiplier(

@@ & ¥ & |5

22 input [7:0] in0,
23 input [7:0] inl,
24 input clk,

25 output [15:0] out
26 1

27

28

29 endmodule

30

Eight_Bit_Multiplier. v B8 ‘ E Design Summary (x| J
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d. Completed code for the 8-bit multiplier is below. You will learn about this syntax in
class.

“timescale 1ns / 1ps

FEEFEEIELLE LS LTI ESFTEE AL LA LS R ELTESEFLE AL LA EEE R P P E S E LA LA i i iiiiiss
/{ Company: UMEC CMPE415

/{ Engineer: Brian W. Stevens

i

/{ Create Date: 13:05:37 02/09/2015

J// Design Name: 8-bit Multiplier

J/{ Module Name: Eight Bit Multiplier

k= // Project Name: ExampleProjectl

10 // Target Devices: Spartan 3E

11 // Tool wversions: Xilinx 13.2

12 // Description: Bn awesome example project for an 8-bit multiplier

L B R

i3 //
14 // Dependencies: 2's complement inputs and 2's complement output
15 /f

16 // Revision: none

17 // Revision 0.01 - File Created

18 // Additional Comments:

s //

20 SASIESIESSAEES ST LA A EErdi i i iidididdifididrdiddiiifriddfiddifidfiriidliiifriiis
21 module Eight Bit Multiplier(

22 input [7:0] in0,

23 input [7:0] inl,

24 input clk,

25 output reg [15:0] out //make sure to include reg

26 )z

27

28 reg [7:0] temp_in0, temp inl;

29 wire [15:0] temp out;

30

31 /{ Perform Logic

32 assign temp_out = {{8{temp in0O[7]}},temp in0} * {{8{temp inl[7]}},temp inl}:
3 f/**% {{8{temp_inO0[7]}},temp_ in0} is used to sign extend temp in0 by & places
B // to match the size of out, this must be done, you will learn about this in class
353

36 // Register input

37 always @ (posedge clk) begin

38 temp_in0 <= in0;

39 temp_inl <= inl;

40 out <= temp out;

41 end

42

43 endmodule

44

Eight_Bit_Multiplier.v B8 | E Design Summary {out of date) 3] I




e. Make sure to check syntax before running simulations of your Verilog modules

|Desigr1 +[0&F X|
=7 | View: @ ﬁl}lmplemenmﬁun ) @Simulaﬁnn
[=| | Hierarchy

18] ExampleProjectl

= £ xc3s500e-4fg320
- []efls Eight_Bit_Multiplier (Eight_Bit_Multiplier)

H|E B || § |6

?J Mo Processes Running

Processes: Eight_Bit_Multiplier

= Design Summary/Reports
Design Utilities
User Constraints
Synthesize - X5T
View RTL Schematic
View Technology Schematic
P2 Check Syntax
“-P)  Generate Post-Synthesis Simulation Model
- f3  Implement Design
-~ P2 Generate Programming File
[ET @ Configure Target Device
-~ g% Analyze Design Using ChipScope

H |82 (38| v

.

=1

& Start | B2 Design | U] Files |TE Libran'es|




11. Creating a Testbench
a. Now we will create a testbench based off our Verilog module
b. Go to Project > New Source
c. Select Verilog Test Fixture and name the file with an extension such as “_tb” or “_test”

[ = ]

& New Source Wizard

Select Source Type

Select source type, file name and its location.
BMM File

&% ChipScope Definition and Connection File
E'J Implementation Constraints File

J IP (CORE Generator & Architecture Wizard)
MEM File

Schematic

System Generator Project

User Document

Verilog Module

Verilog Test Fixture

VHDL Medule Eight_Bit_Multiplier_th
WHOL Library
[¢] VHDL Package

g VHDL Test Bench D:\ExampleProject1 E]
E Embedded Processor

(=) % [ ]

File name:

S=1E]

Location:

Add to project

Mext l ’ Cancel




d. Choose the associate source or the Verilog file you wish to make a testbech for.

@ New Source Wizard

Associate Source

Select a source with which to assodate the new source.

Eight_Bit_Multiplier

[ MNext

] ’ Cancel

e. Click Next
12. Summary of Testbench

-

@ Mew Source Wizard

Summary

Project Navigator will create a new skeleton source with the following specifications.

Add to Project: Yes
Source Directory: D:\ExampleProject1
Source Type: Verilog Test Fixture
Source Mame: Eight_Bit_Multiplier_tb.v

Assodation: Eight_Bit_Multiplier

[ Finish

| [ cance

a. Click Finish



b. Earlier in your Design Hierarchy in the top left of the ISE, you saw that your Verilog
module was under the “Implementation” Section. This views your non-test fixtures.

|Design ~+08 x|
View: @ ﬁl}lmplemenﬁﬁun ™) FE simulation

Hierarchy

ExampleProjectl
= 3 xc3s500e-4fg320

'I|;‘-;ﬁ|i|§m|ﬂ@|:|

c. Click the “Simulation” circle to switch to view your projects simulations files

|Desigr1 =+ 07 X|
View: () i:t':l:EImplemenEﬁon @k simulation

Behavioral |E|

Hierarchy
o ExampleProjectl
= £ xc3s500e-4fg320
=[] Eight_Bit_Multiplier_tb (Eight_Bit_Multiplier_tb.v)
uut - Eight_Bit_Multiplier (Eight_Bit_Multiplier.)

RS

L




d. This opens the file seen below. As you can see this testbench has auto generated inputs
and outputs based on your Verilog module. It also creates an instantiation of the Verilog
module that you are testing, in this case called “uut”, so you can test the module versus
different inputs. It also initializes the inputs to the module you are testing.

1 “timescale 1ns / 1ps
2 SSIIITEIEAT ST T TR AT F R AT T F AT L AT LTI EEL TR TTE AT AATEI AT T Erifiiriiiy
3 // Company:
4 // Engineer:
5 /f
o & // Create Date: 13:16:36 02/09/2015
7 // Design Name: Eight_Bit_Multiplier
] g8 // Module Name: D:/ExampleProjectl/Eight Bit Multiplier tb.v
— 9 // Project Name: ExampleProjectl
A 10 // Target Device:
% 11 // Tool versions:
12 // Description:
A 13 S/
% 14 // Verilog Test Fixture created by ISE for module: Eight_Bit Multiplier
— 15/
@ 16  SISIEELTIEEIFEEETEF LTS FETLE TSRS TP ETE R T TEFELLEETETEEETF PR FEFATEPEEEfiiTs
.D 17 module Eight_Bit_ Multiplier_tb;
= 18 // Inputs
i3 reg [7:0] in0;
20 reg [7:0] inl;
21 reg clk;
22
23 // Outputs
24 wire [15:0] out;
25
26 // Instantiate the Unit Under Test (UUT)
27 Eight Bit_Multiplier uut |
28 .in0 (in0),
23 .inl (inl),
30 clk(clk),
31 .out (ouat)
32 13
24
34 initial begin
as /f Initialize Inputs
36 in0 = 0O;
37 inl
38 clk = 07
39
40 /f Wait 100 ns for global reset to finish
41 #100;
42
43 // Add stimulus here
44
45 end
FE
47 endmodule
48
e m
Eight_Bit_Multiplier.v B Eight_Bit_Multiplier_th.v* B8 ‘ = Design Summary B8




e. Make sure to run Behavioral Check Syntax to check your testbench code before
simulating the behavioral model

|Design +0O8 x|
=7 | View: & !:l':l:E Implementation @) Simulation

Behavioral E

Hierarchy
b ExampleProjectl
B £ xcIs500e-4fg320
=8 Eight_Bit_Multiplier_tb (Eight_Bit_Multiplier_tb.v)
uut - Eight_Bit_Multiplier (Eight_Bit_Multiplierv)

f) B |

o & B || |

P2 No Processes Running

Processes: Eight_Bit_Multiplier_tb
E}y I5im Simulator

- P Behavioral Check Syntax
R Simulate Behavicral Model

H 8| EE| v

|I Start | Ei? Design ’_TE Files |E Libraries|

13. Complete the Test Bench
a. Now itis time for you to write your own testbench, try this link for a tutorial about test
benches and using ISim.

http://www.csee.umbc.edu/~tinoosh/cmpe415/tutorials/ISimTestbenchTutorial.pdf



http://www.csee.umbc.edu/~tinoosh/cmpe415/tutorials/ISimTestbenchTutorial.pdf

b. A sample testbench file is listed here, provided by Dr. Tinoosh Mohsenin

http://www.csee.umbc.edu/~tinoosh/cmpe691/hw/HW1/tbench template.v



http://www.csee.umbc.edu/~tinoosh/cmpe691/hw/HW1/tbench_template.v

