
Lab 1: Tools tutorial 
CMPE 415 

UMBC 
 

February 1st, 2012 
Due February 8th 2012 (at 2:30 pm) 

 
1  Objective 
 
The objective of this lab is to learn the fundamental components of the Xilinx FGPA tools 
required to enter and assemble HDL code using a schematic entry tool and program an FPGA. 
This includes integrating HDL into a schematic, as well as creating and updating symbols. 
 
2  Intro 
 
In this lab you will program an FPGA to display a rectangle on a monitor using a VGA cable. 
You will _rst create an implementation with an error in it and view the results. You will then 
modify the code, update the symbol in the schematic, and wire the schematic correctly to control 
the color of the rectangle using switches. 
 



3 Tutorial Steps

3.1 Start Xlinx Tool

2



3.2 Create New Project

1. In main window menu: File->New Project...

2. You'll now need to enter information about the FPGA. You can look in �Spartan-3E FPGA Family: Data Sheet� under Pack-
age Marking (page 6). To �nd this information. http://www.xilinx.com/support/documentation/data_sheets/ds312.pdf
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3. The next screen shows a summay. Hit Finish. Result:
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3.3 Downloaded HDL Module and Add to project

1. Download a free HDL description of implementation of a vga module to a temporary directory or to your project directory.
Our other module will be implmented using Verilog, but we can integrate Verilog and VHDL modules together in the
schematic if desired. Here are examples of the type of vga modules for which you are looking. Make sure to respect any
restrictions the authors place on copywrighted code that you use.

• http://web.mit.edu/6.111/www/f2005/code/jtag2mem_6111/vga_sync.v Verilog implementation (I sug-
gest this one.)

• http://www.ece.gatech.edu/academic/courses/fpga/Xilinx/downloads/vga_sync.vhd VHDL implementation (handles
blanking internally)

• http://jjackson.eng.ua.edu/courses/ece480/assignments/vga_sync.vhd VHDL implementation with parameters to set
various resolutions (also, implements a �video_on� signal instead of a �blank� signal )

2. There are three places to access the project functions, such as adding a source. You can use any of the following (a,b,c):

(a) Right-click in the Hierarchy plane
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(b) Use the buttons along the left.

(c) Use the main window Project menu
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3. The three functions for sources are:

(a) New Source - starts wizard to create a new source �le (Verilog, VHDL, Schematic, etc...), creating a shell if desired,
and adds it for use in the project.

(b) Add Source - Allows you to point to a source �le in the project directory or anywhere else and include it for use in
the project

(c) Add Copy of Source - Creates a copy of the source �le in the project directory and adds the copy for use in the project

• Add the downloaded HDL �le using option (b) �Add Source� if you initially downloaded the �le to project directory
and use option (c) �Add Copy of Source� if you downloaded it to a temporary directory.
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• You will now have a new source listed.

3.4 Creating a Symbol

1. Select the new HDL source in the Hierarchy panel. In the lower panel expand Design Utilities and double-click �Create
Schematic Symbol�.
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If needed, see help of: Creating a Schematic Symbol from a Source File Help->Help Topics

2. Notice the green check mark added upon success.

3.5 Create Top Schematic

1. Using the main window Project menu, the buttons along the left, or a right-click in the Hierarchy view create a new source.

2. Project->New Source...

3. The New Source Wizard opens

4. Select Schematic as the type and top as the File Name. Click Next.
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5. Click Finish in the following window.

3.6 Add Symbol

1. With your fresh sechmaic showing, select the Symbols tab as pointed out by the cursor in the picture. (use the scroll
buttons just to the right if not shown)
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2. Under Catagories, select your current project.

3. Under symbols, select your new symbol

4. Click in the schematic to add the symbol.
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3.7 Add wire, name it, and and pin

1. Using Add menu or other documented means, choose Add->Wire

2. Click twice to add a simple wire as shown.
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3. Add->Net Name

4. Type Name CLK_50MHZ, and click on wire
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5. Next, add pin (I/O Marker): Use Menu Add->I/O Marker

6. Select �Add an input marker� on left and click on end of wire.

3.8 Add New Source for rectangle display driver using Source Wizard

1. Main window menu: Project->New Source
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2. Select Verilog Module, enter File name vga_rectangle, click Next

3. Set up the IO as shown and then click Next and then click Finish in the following window.
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4. You should now have a shell created with port de�nitions. Set the reg, green, and blue outputs as registers. Implementing
registers avoids glitching (not that it is critical here).
change

output red ,
output green ,
output blue ,

to

output reg red ,
output reg green ,
output reg blue ,

5. Add the following module code:
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parameter WIDTH = 20 ;
parameter HIEGHT = 100 ;
parameter X_LEFT = 320 ;
parameter Y_BOTTOM = 240 ;

// addina l in t e rmed ia t e l o g i c s i g n a l w i r e s
wire f lag_on_rect ; // high only when over r e c t ang l e
wire [ 9 : 0 ] x , y ; // t r a d i t i o n a l ca r t e s ean coord inate s , ( l e f t , bottom )=(0 ,0)

// combinator ia l l o g i c to c a l c u l a t e x , y coord inate system
as s i gn x = pos_h ;
a s s i gn y = 480 − pos_v ;

// combinator ia l l o g i c to dec ide i f beam i s over a rec tange
a s s i gn f lag_on_rect = x >= (X_LEFT) &&

x < (X_LEFT + WIDTH) &&
y >= (Y_BOTTOM) &&
y < (Y_BOTTOM + HIEGHT) ;

// combinator ia l l o g i c and r e g i s t e r s that load on r i s i n g c l o ck edge
always @( posedge c l k ) begin

red <= flag_on_rect & ~blank ;
green <= ~flag_on_rect & ~blank ;

blue <= flag_on_rect & ~blank ;
end

6. Save the �le and generate a symbol as before

3.9 Complete Top Schematic

1. Complete the schematic as follows, including the output markers (be sure to make them as output markers, not input
markers)

• Note the IMPORTANT OPTIONS for the Select(Arrow) tool. Thouroghly understand the �rst three options, reading the
documentation as nessisary. Understanding these options could save you a lot of time.
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3.10 De�ne Pin Locations

1. We need to add a user contrainst �le. Use the new source wizard or create one called top: Project->New Source...
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2. Click Next then Finish.

Page 57 of the developement board user guide provides pin locations for the vga port: http://www.digilentinc.com/Data/Products/S3EBOARD/S3EStarter_ug230.pdf

Appendix B provides an Example User Constraints File (UCF) for the starter board, starting on page 159.

3. Copy the following lines to your UCF:

# ==== Clock inputs (CLK) ====
NET "CLK_50MHZ" LOC = "C9" | IOSTANDARD = LVCMOS33 ;
# Def ine c l o ck per iod f o r 50 MHz o s c i l l a t o r (40%/60% duty−cy c l e )
NET "CLK_50MHZ" PERIOD = 20.0 ns HIGH 40%;
# ==== VGA Port (VGA) ====
NET "VGA_BLUE" LOC = "G15" | IOSTANDARD = LVTTL | DRIVE = 8 | SLEW = FAST ;
NET "VGA_GREEN" LOC = "H15" | IOSTANDARD = LVTTL | DRIVE = 8 | SLEW = FAST ;
NET "VGA_HSYNC" LOC = "F15" | IOSTANDARD = LVTTL | DRIVE = 8 | SLEW = FAST ;
NET "VGA_RED" LOC = "H14" | IOSTANDARD = LVTTL | DRIVE = 8 | SLEW = FAST ;
NET "VGA_VSYNC" LOC = "F14" | IOSTANDARD = LVTTL | DRIVE = 8 | SLEW = FAST ;

3.11 Synthesize, Implement, and Generate Programmaing File

1. On the left, bring up the design view by clicking the design tab

2. Then in the Hierarchy plan, select the top module in the design, top.sch
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3. Finallly, DOUBLE-CLICK Generate Programming File in the plane below.

• �Synthesize� and �Implement Design� are run automatically as needed.

� Sythesize maps your design to a circuit based on FPGA build blocks.

� Implement Design maps the circuit to the FPGA including place and route.

3.12 Program FPGA

We will use the JTAG interface to program the FPGA. While normally separate separate from the FPGA board, the USB-to-
JTAG interface is conveniently built into our starter board.

1. Set Jumper J30 to JTAG Setting

M0=open

M1=short

M2=open
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DO NOT DISCARD JUMPERS, JUST PLACE THEM SO THEY ARE ATTACHED TO ONE PIN TO CREATE OPEN:

2. Connect USB Cable from board to computer

3. Plug in the board's power adaptor to the board's power connector and a 120 V outlet. Turn on the board using the power
switch near the power connector.

4. Double-Click �Con�gure Target Device� under �Generate Programing File�
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Result:
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IF YOU DONT HAVE THIS RESULT SHOWING

THE DEVICE CHAIN THE FIRST TIME YOU

RUN THE TOOL, USE INTRUCTIONS IN SEC-

TION 5 TO MANUALLY START iMPACT, PRO-

GRAM YOUR DEVICE, AND SAVE YOUR CHAIN

CONFIGURATION (.ipf �le)
5. Right-click the xc3s500e device and select �Set Target Device�
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Result:
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6. In iMACT, goto File->Save Project so that you aren't prompted to do this again when starting iMPACT.
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Result:
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3.13 Connect to Monitor

Connect a VGA cable to the starter board and a monitor. You should see a magenta/purple rectange on a blue background.

4 Your Design Assignment:

Modify the design to have the ability to change the color of the rectangle and set the background to black based on switch
positions.

• The color should be determined by turning on one of threee switches, otherwise the rectangle is black.

• The three switches should correspond to yellow, cyan, and magenta. Having more than one switch on at a time is a �don�t
care� condition.

The board's user manual provides a color chart in the VGA port section. It also provides and all the pin location information
needed to add the appropriate information to your user contrainsts �le for the switched.

NOTE: When you update the port de�nitions of a module, you need to manually regenerate the symbol by running �Create
Schematic Symbol� again. When you reopen a schematic with that symbol, it will present you withe the option to update them.
Just click �Update Intances�.
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5 Running iMACT Manually

1. In ISE main menu: Tools->iMACT. Reply Yes/OK to any prompts.

2. In iMPACT menu, Edit->Launch Wizard...
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3. Click OK

4. Click YES in following window.
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5. Select your bit �le:
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6. Select no (we will not load anything onto the FPGA ROM

7. For the following two devices, select bypass:
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8. Just HIT OK HERE:
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9. Select FPGA device:

10. Program device:
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Result:
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11. Use File ->Save Project to save chain con�guration.

When you update your programming �le (.bit) you may have to reload it by right-
clicking the �rt device in the chain, the FPGA, and using �Assign New Con�gu-
ration File.�
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